Difference between revisions of "Home-assistant"

From DWIKI
m
(18 intermediate revisions by 2 users not shown)
Line 2: Line 2:
Home assistant
Home assistant


 
 
 


= Links =
= Links =


*[https://www.home-assistant.io Homepage]  
*[https://www.home-assistant.io Homepage]
*[https://www.home-assistant.io/docs/glossary/ Home Assistant Glossary]  
*[https://www.home-assistant.io/docs/installation/virtualenv/ Installing in python virtual environment] (remember to pip install --upgrade pip first)  
*[https://www.home-assistant.io/docs/installation/virtualenv/ Installing in python virtual environment] (remember to pip install --upgrade pip first)  
*[https://github.com/geekofweek/homeassistant/ a lot of examples]  
*[https://github.com/geekofweek/homeassistant/ a lot of examples]  
Line 23: Line 19:


*[https://www.home-assistant.io/integrations/mqtt/ https://www.home-assistant.io/integrations/mqtt/]  
*[https://www.home-assistant.io/integrations/mqtt/ https://www.home-assistant.io/integrations/mqtt/]  
==Automations ==
== Triggers ==
[[Category:Domotics]]
https://www.home-assistant.io/docs/automation/trigger
On multiple triggers logical OR applies


= Cards =
= Cards =
Line 32: Line 39:
= HOWTOs =
= HOWTOs =


==Logging==
See [https://www.home-assistant.io/integrations/logger/ logger]
== Add rfxtrx device ==
== Add rfxtrx device ==


Line 59: Line 68:
       name: myswitch1
       name: myswitch1


== Migration to mysql ==
==Splitting configuration==
https://www.home-assistant.io/docs/configuration/splitting_configuration
=== Including files in configuration.yaml ===
 
group: !include groups.yaml
 
In groups.yaml:
 
samplegroup:
  name: my.samplegroup
  entities:
  - binary_sensor.one
  - binary_sensor.two
 
=== Automations ===
 
Using this line your automations get saved here
 
automation: !include automations.yaml
 
script: !include scripts.yaml
 
=== templates ===


*[https://www.srm.im/2017/06/11/home-assistant-migration-from-sqlite3-to-mariadb-mysql/ https://www.srm.im/2017/06/11/home-assistant-migration-from-sqlite3-to-mariadb-mysql/]
template: !include templates.yaml


 
TODO CHECK THIS
In templates.yaml:


 
- binary_sensor:
  name: "Is closed"
  state: >-
    {{ is_state('binary_sensor.openclose_30','on')
or is_state('binary_sensor.openclose_31','on') }}


 
== Migration to mysql ==


*[https://www.srm.im/2017/06/11/home-assistant-migration-from-sqlite3-to-mariadb-mysql/ https://www.srm.im/2017/06/11/home-assistant-migration-from-sqlite3-to-mariadb-mysql/]


==Update letsencrypt cert=
certbot certonly --standalone
/etc/letsencrypt/live/hass.example.com/* ~hass/.homeassistant/certs/


= FAQ =
= FAQ =
Line 77: Line 117:
Means disabled, just click on edit icon and enable it
Means disabled, just click on edit icon and enable it


 
==This entity does not have a unique ID==
probably means adding "entity_id: foo.bar"


==Error during logbook entry retrieval =
== Error during logbook entry retrieval ==


refresh browser
refresh browser
==Offset==
-1:15:00
== Binary sensors ==
=== Door open or closed ===
on  = Open
offf = Closed


 
 


== Binary sensors ==
In a group:
===Door open or closed ===
 
On = Open
Open + Closed = Open
Off = Closed
 
 
 
 


== Platform configuration is deprecated ==
== Platform configuration is deprecated ==
Line 100: Line 158:


 
 


== Upgrading home-assissant ==
== Upgrading home-assissant ==
Line 111: Line 170:
  source bin/activate
  source bin/activate
  pip3 install --upgrade homeassistant
  pip3 install --upgrade homeassistant
 


== Find new zigbee device via conbee/deconz ==
== Find new zigbee device via conbee/deconz ==
Line 123: Line 184:


after a while it should also show up in Configuration->Entities (TIP: here change the Entity ID to something more useful)
after a while it should also show up in Configuration->Entities (TIP: here change the Entity ID to something more useful)
The name you give the device on the deconz interface will show up in HA under "'''Devices'''"


== Reload configuration.yml ==
== Reload configuration.yml ==
Line 128: Line 191:
That's done by the "restart server", make sure to run "check configuration" first
That's done by the "restart server", make sure to run "check configuration" first


===Where did "check configuration" go?===
Developer Tools->Services
=== reload configuration from commandline ===
=== reload configuration from commandline ===


Line 163: Line 228:


 
 


== Frontend ==
== Frontend ==


=== Show badge only when condition met ===
=== Show badge only when condition met ===
https://community.home-assistant.io/t/conditional-badge-at-all-possible/133313/5


         style: |
         style: |
Line 202: Line 269:


I found simply restarting home-assistant made this go away again
I found simply restarting home-assistant made this go away again
==ZHA==
[https://www.home-assistant.io/integrations/zha/ Zigbee Home Automation]
Probably the best way to use zigbee now


= Customizing home-assistant =
= Customizing home-assistant =


== Module card-mod ==
== Module card-mod ==
==Custom-UI

Revision as of 21:38, 3 October 2022

Home assistant


Links

Home assistant and MQTT


Automations

Triggers

https://www.home-assistant.io/docs/automation/trigger On multiple triggers logical OR applies

Cards

HOWTOs

Logging

See logger

Add rfxtrx device

but when you don't see new switch. enable debugging in configuration.yaml:

logger:
  default: info
  logs:
    homeassistant.components.rfxtrx: debug
rfxtrx:
 device: /dev/ttyUSB0-RFX433XL
 debug: true

and look for

homeassistant.components.rfxtrx] Receive RFXCOM event from (Device_id: 1ed0732_3 Class: LightingDevice Sub: 0, Pkt_id: 0b10000101ed071303010f60)

and use the Pkt_id in your configuration:

switch:
  platform: rfxtrx
  devices:
    0b10000101ed071303010f60:
      name: myswitch1

Splitting configuration

https://www.home-assistant.io/docs/configuration/splitting_configuration

Including files in configuration.yaml

group: !include groups.yaml

In groups.yaml:

samplegroup:
  name: my.samplegroup
  entities:
  - binary_sensor.one
  - binary_sensor.two

Automations

Using this line your automations get saved here

automation: !include automations.yaml

script: !include scripts.yaml

templates

template: !include templates.yaml

TODO CHECK THIS In templates.yaml:

- binary_sensor:
  name: "Is closed"
  state: >-
    {{ is_state('binary_sensor.openclose_30','on') 
or is_state('binary_sensor.openclose_31','on') }}

Migration to mysql

=Update letsencrypt cert

certbot certonly --standalone
/etc/letsencrypt/live/hass.example.com/* ~hass/.homeassistant/certs/

FAQ

The device is disabled by Config entry.

Means disabled, just click on edit icon and enable it

 

This entity does not have a unique ID

probably means adding "entity_id: foo.bar"

Error during logbook entry retrieval

refresh browser

Offset

-1:15:00

Binary sensors

Door open or closed

on  = Open

offf = Closed

 

In a group:

Open + Closed = Open

 

 

Platform configuration is deprecated

"platform" being used in configuration file, while the integration no longer needs that

Config error. See dev-info panel for details.

That's under "Developer tools" tab "Logs"

 

 


Upgrading home-assissant

For this is, as user hass:

 

cd homeassistant
#python -m venv . ??
source bin/activate
pip3 install --upgrade homeassistant

 

Find new zigbee device via conbee/deconz

Assuming phoscon already found it: Got to Developer Tools->Services and enter

deconz.device_refresh

and then look in home-assistant.log for a lines like

INFO (MainThread) [homeassistant.helpers.entity_registry] Registered new sensor.deconz entity: sensor.temperature_20

after a while it should also show up in Configuration->Entities (TIP: here change the Entity ID to something more useful)

The name you give the device on the deconz interface will show up in HA under "Devices"

Reload configuration.yml

That's done by the "restart server", make sure to run "check configuration" first

Where did "check configuration" go?

Developer Tools->Services

reload configuration from commandline

hass --script check-config ??

Unable to open database "home-assistant_v2.db": file is encrypted or is not a database

try

sqlite3 home-assistant_v2.db

 

Test templates

ansible localhost -m debug -a 'msg=Template:"0.005"'

 

homeassistant.exceptions.HomeAssistantError: Entity id already exists

In at least one case restarting home-assistant fixed it (deconz sensor)

Unable to open the Home Assistant UI in a browser.

??

AttributeError: module 'homeassistant.util.yaml.loader' has no attribute 'Secrets'

An integration needs upgrading

UI showing "restored" in red

was re-enabled but without data (yet?)

 


Frontend

Show badge only when condition met

https://community.home-assistant.io/t/conditional-badge-at-all-possible/133313/5

       style: |
         :host {
              display: {% if states('sensor.motion_living_battery') | float > 90 %} none; {% endif %}
         }

Terms and meanings (or my guesses at it)

device

seems to exist only if discovered?

service

entity

a gnome?

 

Platform

https://developers.home-assistant.io/docs/creating_platform_index/

 

binary_sensor

https://esphome.io/components/binary_sensor/homeassistant.html

deconz

pydeconz.errors.Unauthorized: /lights/2/state unauthorized user

I found simply restarting home-assistant made this go away again


ZHA

Zigbee Home Automation Probably the best way to use zigbee now

Customizing home-assistant

Module card-mod