Difference between revisions of "Home-assistant"

From DWIKI
m
m
Line 54: Line 54:
==Migration to mysql==
==Migration to mysql==
*https://www.srm.im/2017/06/11/home-assistant-migration-from-sqlite3-to-mariadb-mysql/
*https://www.srm.im/2017/06/11/home-assistant-migration-from-sqlite3-to-mariadb-mysql/




Line 119: Line 120:


??
??
     
 
== AttributeError: module 'homeassistant.util.yaml.loader' has no attribute 'Secrets'==
== AttributeError: module 'homeassistant.util.yaml.loader' has no attribute 'Secrets' ==
 
An integration needs upgrading
An integration needs upgrading
==UI showing "restored" in red==
was re-enabled but without data (yet?)


=Terms and meanings (or my guesses at it)=
=Terms and meanings (or my guesses at it)=

Revision as of 15:56, 20 June 2021

Home assistant




Links

Home assistant and MQTT

Cards

HOWTOs

Add rfxtrx device

but when you don't see new switch. enable debugging in configuration.yaml:

logger:
  default: info
  logs:
    homeassistant.components.rfxtrx: debug
rfxtrx:
 device: /dev/ttyUSB0-RFX433XL
 debug: true

and look for

homeassistant.components.rfxtrx] Receive RFXCOM event from (Device_id: 1ed0732_3 Class: LightingDevice Sub: 0, Pkt_id: 0b10000101ed071303010f60)

and use the Pkt_id in your configuration:

switch:
  platform: rfxtrx
  devices:
    0b10000101ed071303010f60:
      name: myswitch1

Migration to mysql



FAQ

Config error. See dev-info panel for details.

That's under "Developer tools" tab "Logs"

 

 

Upgrading home-assissant

For this is, as user hass:

 

cd homeassistant
#python -m venv . ??
source bin/activate
pip3 install --upgrade homeassistant

Find new zigbee device via conbee/deconz

Assuming phoscon already found it: Got to Developer Tools->Services and enter

deconz.device_refresh

and then look in home-assistant.log for a lines like

INFO (MainThread) [homeassistant.helpers.entity_registry] Registered new sensor.deconz entity: sensor.temperature_20

after a while it should also show up in Configuration->Entities (TIP: here change the Entity ID to something more useful)

Reload configuration.yml

That's done by the "restart server", make sure to run "check configuration" first

reload configuration from commandline

hass --script check-config ??

Unable to open database "home-assistant_v2.db": file is encrypted or is not a database

try

sqlite3 home-assistant_v2.db

 

Test templates

ansible localhost -m debug -a 'msg=Template:"0.005"'

 

homeassistant.exceptions.HomeAssistantError: Entity id already exists

In at least one case restarting home-assistant fixed it (deconz sensor)

Unable to open the Home Assistant UI in a browser.

??

AttributeError: module 'homeassistant.util.yaml.loader' has no attribute 'Secrets'

An integration needs upgrading

UI showing "restored" in red

was re-enabled but without data (yet?)

Terms and meanings (or my guesses at it)

device

seems to exist only if discovered?

service

entity

a gnome?

deconz

pydeconz.errors.Unauthorized: /lights/2/state unauthorized user

I found simply restarting home-assistant made this go away again

Customizing home-assistant

Module card-mod

==Custom-UI