Difference between revisions of "Home-assistant"

From DWIKI
Line 31: Line 31:
     0b10000101ed071303010f60:
     0b10000101ed071303010f60:
       name: myswitch1
       name: myswitch1
==Migration to mysql==
*https://www.srm.im/2017/06/11/home-assistant-migration-from-sqlite3-to-mariadb-mysql/


=FAQ=
=FAQ=

Revision as of 19:28, 18 July 2020

Home assistant

Links

HOWTOs

Add rfxtrx device

but when you don't see new switch. enable debugging in configuration.yaml:

logger:
  default: info
  logs:
    homeassistant.components.rfxtrx: debug
rfxtrx:
 device: /dev/ttyUSB0-RFX433XL
 debug: true

and look for

homeassistant.components.rfxtrx] Receive RFXCOM event from (Device_id: 1ed0732_3 Class: LightingDevice Sub: 0, Pkt_id: 0b10000101ed071303010f60)

and use the Pkt_id in your configuration:

switch:
  platform: rfxtrx
  devices:
    0b10000101ed071303010f60:
      name: myswitch1

Migration to mysql

FAQ

Config error. See dev-info panel for details.

That's under "Developer tools" tab "Logs"


Upgrading home-assissant

For this is, as user hass:

cd homeassistant
source bin/activate
pip3 install --upgrade home-assistant


Find new zigbee device

Assuming deconz/phoscon: Got to Developer Tools->Services and enter

deconz.device_refresh


Reload configuration.yml

That's done by the "restart server", make sure to run "check configuration" first

Unable to open database "home-assistant_v2.db": file is encrypted or is not a database

try

sqlite3 home-assistant_v2.db


Test templates

ansible localhost -m debug -a 'msg=Template:"0.005"'


homeassistant.exceptions.HomeAssistantError: Entity id already exists

In at least one case restarting home-assistant fixed it (deconz sensor)

Terms and meanings (or my guesses at it)

device

seems to exist only if discovered?

service

entity

a gnome?

deconz

pydeconz.errors.Unauthorized: /lights/2/state unauthorized user

I found simply restarting home-assistant made this go away again